SQL2008附加数据库时提示版本为661,此服务器支持655及更低版本,不支持降级路径…….

 其实这个问题很简单,为sql server 2008 r2的版本是661,而sql server 2008 sp1的版本是665,所以出现上述问题。问题是我一直用的数据库都是sql server 2008 r2怎么会出现sql server 2008 sp1版本的呢。我查找了一下程序果然发现我的程序里装有sql server 2008 sp1,这是怎么装上的呢?

  原来是装vs2010时,vs2010中自带的有一个简化数据库,就是sql server 2008 sp1版本的,这个数据库也是可以用的,很多人不知道怎么用它,其实只需要去下载一个图形包安装就行了。

  找到问题之后,也就有了解决办法,把数据库恢复成sql server 2008 sp1的即可以了,或则是用sql server 200 r2的,把一个数据库卸载掉。

未经允许不得转载:王刚博客 » SQL2008附加数据库时提示版本为661,此服务器支持655及更低版本,不支持降级路径…….

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏